解决Typecho更改php版本出现”Database Server Error”错误

  • 我们再使用Typecho程序的时候,经常会遇到一些问题,自己又无法解决,今天修改php版本的时候就遇到了一个问题,经过排查,找到了问题原因,这里分享给大家,希望以后能帮助到大家!

  • 切换php版本后网站出现”Database Server Error”错误,这个问题是我把网站 php5.6 切换到 php7.1 以后出现的,刚开始我也是懵逼,因为我另外一个站使用同样的源码,能够正常使用,所以绝对不是源码的问题,然后我就开始排查问题了。
图片[1]-解决Typecho更改php版本出现”Database Server Error”错误-宅学院

数据库文件没有修改、网站文件也没有修改,出现 Database Server Error 错误。可以肯定的是数据库和文件确实没有问题。但是 php7.1 版本和数据库 mysql5.6 也没有问题,后来搜索到相关文章,需要将数据库引擎修改成 Pdo_Mysql

图片[2]-解决Typecho更改php版本出现”Database Server Error”错误-宅学院

我将 typecho 根目录下的 config.inc.php 数据库链接文件上图位置,将 Mysql 换成 Pdo_Mysql 。然后网站就正常了。


© 版权声明
THE END
可以支持一下喵喵吗😽
点赞0赞助 分享
我有话说 抢沙发